
Exercise 4 

4.   Culverts 
This exercise shows the user how to use the culvert module to design a culvert. The 
culvert module acts as a standalone component of GEOPAK Drainage, meaning it does 
not directly interact with Drainage Areas, Nodes, Links or Networks. 

4.1 Delineate the Drainage Area 
a) Use DTM tool Delineate Watershed to create the drainage area shown 

below. If necessary, refer back to exercise 3.2 to create the drainage area. 

 The following shape will be used below as the drainage area for this exercise. 

NOTE: The area shown below on level SURVEY - DRAINAGE - Area Shapes extends 
to the limits of the current TIN file. Inspection of the contours will reveal that the 
drainage area most likely extends beyond these limits. Appendix B will discuss options 
to approximate the full extent of the drainage area. 
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b) From the GEOPAK Drainage menu bar select Component>Area>Add.  

Type in 23+20 for the Area ID.  Click OK. 

 

c) Click the Select Shape button. Select and data point to accept the shape 
shown in the first step. The area is automatically calculated. 
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d) Set the Base C Value to 0.350 and click on Compute TC 

 
When the following Dialog will appears, use the explorer button to select the correct TIN 
file. 
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e) Expand window to show details and set Max Sheet Flow Distance to 300’ and 
Max Shallow Flow Distance to 100’. 

 
Collapse the window, toggle ON Sheet Flow, Shallow Flow and Concentrated Flow and 
fill in the values as follows: 

n Value: 0.400 

Inter. K: 0.457 

Velocity: 5.000 

n Values for different surface types are available in the TDOT Drainage Manual, Table 
4-3 Manning’s n Values for Overland Flow 

Intercept K values are below: 

Land Cover / Flow Regime k 
Grassed waterway (shallow concentrated flow) 0.457 

Unpaved (shallow concentrated flow) 0.491 

Paved area (shallow concentrated flow); small upland gullies 0.619 
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Exercise 4 

NOTE:  See Appendix D for additional Manning's N and Intercept K Values. 

f) Click Trace and data point at the furthest hydraulic point. Once values are calculated, 
click Compute. Then click Apply. 
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The Drainage Area Definition is now filled out. 

 

NOTES:  
Minimum Time of Concentration is 5 minutes. If computed time is less than 5 minutes 
input 5 manually. 

For urban areas adjust maximum sheet flow as required. 

For areas that drain directly from sheet flow to concentrated flow, uncheck the Shallow 
Flow box. Leaving this box checked and setting it to zero will not allow TC to be calculated 
correctly. 

After the drainage area has been set up, runoff coefficients can be automatically computed 
with the use of Land Use Items from the Drainage Library. Click on Subareas in the 
Details list on the left.  

 

4-6   Culverts GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 4 

g) Toggle ON Display Only and then click the Automatic Delineation button.  The file is 
scanned for closed shapes matching the Land Use symbology specified in the Drainage 
Library (Land Use Tab).  

 

 

 

h) Click the Apply button to apply the land uses (and their “C” values) to the Drainage 
Area. 
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i) We want to compute the discharge for a 50-year storm so if that is not already set; select 
Project>Preferences>Frequency Options and change the Frequency to the 50-year 
storm. Click the OK button to accept the new preference setting. 

 

j) Return to the Drainage Area Computations>Computation dialog box and click the 
Compute Discharge button: 

 

Verify the Computations; then click Apply to add the Area to the Project. 
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k) Jot down the Computed Discharge from the 50-year storm computed in the step above 
here: ____________ 

l) Recompute the drainage area discharge for the 100 Year storm.  Select 
Project>Preferences>Frequency Options and change the Frequency to the 100 year 
storm. Click the OK button to accept the new preference setting. 

 

m) Return to the Drainage Area Definition dialog box and click the Compute Discharge 
button: 

 

 

n) Jot down the Computed Discharge from the 100-year storm computed in the step above 
here: ____________ 

o) Close the Drainage Area Definition dialog box.  

p) Change the Frequency back to the 50 Year storm 
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4.2 Design the Culvert 
a) From the Drainage main menu, select Component > Culvert> Add. 

 

 

b) Click on the Add button to add a new culvert.  Enter the Culvert Name as 23+20 (station 
of the culvert) and Click OK. 
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c) The Culvert dialog will open as seen below: 

 

d) Enter the culvert discharges from Steps 11 and 14 in the previous exercise. Key-in the 
discharges in the key-in field and click the Add List Item button for each discharge 

  

e) Highlight the 50-yr storm and click Select Discharge. This will be the Discharge that the 
culvert is designed for. 
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You could also just double click to set the desired Design Discharge that the culvert is 
designed for. 

 
f) Define the tailwater.  Set the Tailwater option to Compute and key-in the slope and N 

Value.  

NOTES:  
This slope is the longitudinal slope of the downstream channel. This slope can be 
determine utilizing the Analysis tool: Height/Slope located in 
Applications>GEOPAK>ROAD>DTM Tools 

N Values for different surface channels are available in the TDOT Drainage Manual, 
Table 5A-1 Values of Roughness (See Appendix E). 

 

Set the Slope % to 0.800 and the N Value to 0.040 and click the Extract Cross 
Section button. 
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g) The Define Culvert Tailwater Cross Section dialog will open. Set to Drape Element 
on Model/TIN and TIN File.   
 
Click on the Select Files button and select final.tin. 

 

h) Click the Place Element button to locate the postion of the tailwater cross section that 
is to be extracted (this is notated as the ‘Extracted Profile’ on the dialog).: 
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i) The Define Culvert Tailwater Cross Section dialog will now contain the profile along 
the element placed representing the channel cross section at this location. 

 

j) Click the OK button and the main culvert dialog will open again. The values for the 
tailwater section will now be populated. 
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k) Select the Configuration tab to define the type of Culvert. Make settings as listed below. 

 

Shape: Circular  
(Culvert Shape: Circle, Box, Ellipse, Etc.) 

Material: Concrete  
(Culvert Material: Concrete, Steel, Plastic, Etc.) 

Headwater Elevation: 836.50  
(The maximum elevation the water can reach at the upstream end of the culvert).  
By default this option is set to Allowable Headwater which uses a height value, 
click to change to Headwater Elevation. 

Maximum Rise: 5.000  
(The maximum diameter, height of the culvert) 

Minimum Rise: 1.500  
(The minimum diameter, height of the culvert) 

Design Barrels: Toggle ON  
(Allows the program to design multiple barrels, if required) 

Number of Barrels: 1 

Roughness: 0.013   
(Determined by the type of Material, See the TDOT Drainage Manual Section 
6.04.2.4.3, Culvert Roughness Coefficients) 

NOTE: If you know the size of culvert you need beforehand you may set Culvert Size to 
‘Library Item’ and pick from the list of defined items. 
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l) Click Select Entrance and select the appropriate entrance condition. The most 
commonly used for TDOT projects is Headwall beveled 45^. Select this condition and 
click ok. This will automatically set the Entrance Ke value. 

 
m) Select the Headwall Location tab to define the location of the Upstream Headwall and 

Downstream Headwall (nodes).  Make settings as listed below. 
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Type: Plan View 

Reference Chain: CL  
(Roadway Centerline) 

TIN File: final.tin 

Library Item: Culvert Endwall 

Alignment: Tangent to Ref. Chain 

+ Angle.: 0 or 180  
(For headwalls parallel to the roadway on the right side use an angle 
adjustment of 180 and on the left use 0. In this case the upstream is on 
left so that value should be set to 0.) 

NOTE:.Another option is to use Mirror Cell. Set angles to 0 and Toggle 
ON for headwalls on the right of the roadway and Toggle Off for headwalls 
on the left of the roadway. Do NOT use Mirror Cell along with Angle 
Rotations as this adds confusion. 

Invert Elev.: TIN / Model  
(Reads TIN elevations. Use ‘User Supplied’ inverts are known or are 
different than TIN file.) 

n) Locate the Upstream Headwall by clicking the Dynamic Place button and setting the 
upstream headwall at a location similar to that shown below:  
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Watch the Headwall Cross Section dialog box 
appear upon mouse-movement.  Use this viewer 
to place the Headwall at the upstream low point.   

Station and offset values for the headwall location 
should change dynamically in the dialog as you 
move your mouse. If not, reset the chain name 
and try Dynamic Place again. It may be 
necessary to close the tool and reopen.  

NOTES:  
To set the headwall locations for 90 degree cross drains, you can enter the centerline 
crossing station with a given offset and click the Keyin Place button. 

You may wish to utilize the DTM Tools>Low Point Tool as discussed in the DTM Tools 
Section 3 in order to predetermine the low point locations. 

o) Locate the downstream headwall by clicking Dynamic Place under the Downstream 
Headwall group.  

 

4-18   Culverts GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 4 

 
 

p) Select the Overtopping tab to define the limits of roadway overtopping. Make settings 
as listed below and click Extract PGL Profile.  

NOTE: This step is only necessary if your culvert is in a sag condition. If you are not in a 
sag condition you may proceed to Step 17. 
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Overtopping Source: PGL 
(This option sets the roadway profile as the controlling surface elevation for 
overtopping. Other options include ‘User Supplied’ or constant elevation and 
‘DTM’) 

Width: 48.00  
(This is the width of your roadway) 

Pavement: Toggle ON  
(This should be checked unless your road is not paved) 

Reference Chain: CL  
(Roadway Centerline) 

Ref. PGL: DESIGNCL  
(Roadway Profile) 

Begin Station: 22+00.00  
(Use the DP button to select a point before the Culvert.) 

End Station: 25+00.00  
(Use the DP button to select a point after the Culvert.) 

X Increment: 5.000  
(This may be automatically adjusted depending on the distance between the 
begin station and end station.) 

q) Once the Nodes have been located, and the elevations appropriately calculated, the 
Culvert can be added to the project. Click the Apply button and the culvert will be drawn 
and labeled according to the symbology in the Preferences. 

r) The information to this point is enough to check the culvert computations. Select the 
Computations tab. Toggle on the option to view the Culvert calculations. Click the 
Compute Culvert button to perform the calculations. 
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NOTE: You may include Tailwater and Overtopping calculations (if you need them) by 
toggling ON the option to view them. 

 

 

To view the Culvert Design Results, simply press the "View" button on the lower right of 
the "Culvert" menu to access the output file or you could open the file "23+20.out" from 
your Project Folder.  View and/or print the Culvert Design Results that the Geopak 
Drainage software has calculated for you.  Alternate design options have been found that 
may be considered.  

 

The report also includes hydraulic computations such as Maximum Head Water Depth and 
Outlet Velocity for Q50 and Q100 which are helpful in analyzing the culvert design. 
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For the 50 year storm, the Head Water Depth is 835.926 ft.  Using the DTM Height/Slope 
tool, a shape may be drawn at that elevation which represents the water surface for this 
storm event.  This is the white shape in the picture below.    
    

       
 
 
The Microstation Change Element Fill Type tool can be used to illustrate the ponded water 
for visual analysis.  Use the Change Attributes tool to change the color to blue if desired. 
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Be sure that your Fill is toggled On in the View Attributes menu. 
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Similarly, a visualization of the Tail Water pond may be created. 
 

 
 

The Drainage Manual states that outlet velocities on Culverts should be based on the 50 
year storm.  In our file 23+20.out, we see that Geopak Drainage has calculated the Outlet 
Velocity for the 50 year storm at 13.567 fps.  
 

 
 
 
The use of riprap as scour protection at a culvert outlet is discussed in Section 6.04.3.3 of 
the Drainage Manual.  It says that riprap can be used to provide protection at a culvert 
outfall for velocities between 5 fps and 12 fps.  Since our velocity is greater than 12 fps, we 
would either need to lessen the slope of the culvert, thereby reducing the velocity at the 
outlet, or we would need to design a stilling basin or some other type of energy dissipator. 
See the Drainage Manual for guidance. 
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Before the next step, go back to “Configurations”, change Culvert Size to “Library 
Item” - 36 Inch Dia Circular. Then, select the Culvert Size drop down and switch 
it to Design Size and set the Maximum Rise to 3. 

 

  

 

 

4.3 Culvert Profile 
At this point, the designer has the pipe size that will be required and can use regular 
Geopak proposed cross section tools to set up a culvert section to finalize the length & 
inverts for the cross drain. 
The next several steps illustrate the functionality available through Geopak Drainage to set 
up a culvert section in profile format along the cross drain.  
a) On the Headwall Location tab click on Create Profile to set up a culvert section and 

finalize headwall locations. The Create Plan View Culvert Profile dialog will open up. 
Make settings as shown below.  

Set Horiz scale 10 and Vert scale 10. 

Change max and min elevations to be the next even 10' up or down.  

Use default values for Max and Min station.  
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b) Click on the Symbology tab and make the following settings: 

 
Ground Line Symbology (Proposed Roadway):  

LV= DESIGN - TYPICAL - Finished Grade and 
Subgrade  
CO= 6, Style=0, WT=4 

Boundary Symbology:  
LV= DESIGN – SHEET – Light Grid 
CO=2, Style=0, WT=4 
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Vertical Grid Major Interval:  
ON, Value=10 

Vertical Grid Minor Interval:  
OFF 

Vertical Grid Major Symbology: 
LV= DESIGN – SHEET – Light Grid  
CO=0, Style=1, WT=1 

Vertical Major Text: 
LV= DESIGN – SHEET – Corner Text 
CO=6, WT=10, TH=2, TW=2, FT=LEROYMON(3) 
Click the Top Center to set Justification 

Horizontal Grid Major Interval:  
ON, Value=10 

Horizontal Grid Minor interval:  
OFF 

Horizontal Grid major symbology: 
LV= DESIGN – SHEET – Light Grid  
CO=0 Style=1 WT=1 

Horizontal Major Text: 
LV= DESIGN – SHEET – Corner Text 
CO=6, WT=10, TH=2, TW=2, FT=LEROYMON(3) 
Click the Middle Right to set Justification 

 
c) Once symbologies are set click on the Section tab and click on Place Profile in the 

lower right of the dialog. Culvert Section graphics will appear on the cursor, Data Point 
out in the open somewhere to place the graphics. Click OK on Create Plan View 
Culvert Profile dialog  to dismiss and reopen the Culvert Edit dialog.  Click Apply to 
store the culvert information. 

  

d) Now that we have placed our culvert section we can finalize our inlet and outlet 
locations. On the Headwall Location tab change Type from Plan View setting to Profile 
View. When prompted to "Convert Plan View Culvert to Profile Culvert" click OK: 
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e) The Headwall location tab will change to show Profile view controls.  

 

 

f) Under Upstream Headwall controls click Station DP button.  Move cursor over 
culvert section profile near the upstream end of pipe. That end will start dynamically 
tracking with cursor movement. Relocate inlet so that the upstream invert of the pipe 
coincides with roadway side slope.  

 NOTE: This location could  be located previously with Microstation commands or 
calculated and input as values in the Invert Sta. & Invert Elev. Keyin fields. 
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g) Repeat this procedure on the Downstream Headwall by clicking on Station DP and 
locating in culvert section profile.  

 

 
h) Once Headwall locations have been reset click on Apply in the upper right corner of the 

Culvert Edit dialog. Now go back to the Computation tab  and this time before clicking 
on Compute Culvert, toggle ON option for Output to ASCII, keyin name 23+20.txt and 
set file to Create option.  

When Compute Culvert is clicked the output data in dialog is updated and text output 
file is created.   
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i) To place drainage info with culvert section profile : 

Set active text settings by going to TDOT>Cross Sections>XS Text Styles Plus, set 
Scale to 10 and select XS Drainage - Prop.: 

 
Go to Microstation's File>Import>Text and pick the file 23+20.txt in your project 
directory. Data Point in the DGN file for placement near the culvert section profile.  This 
data can now be used when filling out TDOT Standard Drainage Data cells or can be 
edited to show additional data needed with the culvert section. 
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